• centOS上git提交代码流程

    admin 2022-03-27

    git add git commit

    1.在文件夹里先同步代码:git pull2.查看当前代码状态:git status3.如果是以前的文件夹,先复制过来:\cp -rf  原来的文件夹  新文件夹这个命令是直接覆盖原来存在的文件4.添加变更:git ad......

    293 0

  • centos安装gitee并拉取码云

    admin 2022-03-27

    centos git

    第一步:yum -y install git2.查看版本:git --version出现 git version 1.8.3.1 说明安装成功。3.在想要设置仓库的地方建好文件夹:mkdir giteecd gitee4.设置公钥......

    295 0

  • CentOS搭建FTP并禁止FTP用户登录SSH

    admin 2021-11-29

    搭建FTP,Linux FTP,禁止FTP登录ssh

    好久没用FTP了,最近需要搭建一下FTP,所以记录一下过程:服务器:阿里云CentOS登录后执行:yum -y install vsftpd安装完成后,启动ftpsystemctl start vsftpdsystemctl enable ......

    571 0

  • Thinkphp5.1上传文件到阿里云OSS

    admin 2021-10-26

    上传文件,阿里云OSS上传,文件上传到OSS,OSS文件上传,OSS上传

    上传文件到阿里云OSS里,需要注意的是,文件要先传到服务器或者用本地的绝对路径。根据文档,先安装SDK:composer require aliyuncs/oss-sdk-php资源名称就是Bucket列表里的名称:文件夹列表:上传方法放到......

    627 0

  • ThinkPHP5.1接入微信支付V3及避坑指南

    admin 2021-10-24

    微信支付,微信支付V3,PHP微信支付,微信nativePay支付,微信jsapi支付

    之前的网站涉及到微信支付都是用的v2版本,好久也没更新了,没出问题也没去管,最近新做了一个项目,发现V3都出了好久了,然后就去研究了一下,踩了一点坑,记录一下。(注意:百度出来的大部分都是扯淡的)老规矩,先看文档( 这里强调一下前......

    1795 0

  • bootstrap4 弹框(modal)里js不执行解决办法

    admin 2021-07-14

    bootstrap4 modal,

    bootstrap3里的modal在bootstrap4里面不执行,查了很多资料,发现了解决办法:这是页面html:<div class="modal fade bs-example-modal-lg" id="modal" tabi......

    877 0

  • Mac更新10.15.5后svn报错The subversion command line tools are no longer provided by Xcode.

    admin 2020-06-25

    The subversion command line tools are no longer provided by Xcode.

    手贱更新了一下Mac系统,然后svn就不能用了,具体报错如下:The subversion command line tools are no longer provided by Xcode.百度查了一下网上的方法:解决方案:sudo r......

    5015 0

  • thinkphp5.1接入银联支付

    admin 2020-04-08

    银联支付,tp5.1银联支付

    最近项目中要用到银联支付,所以记录一下开发过程:1.先去银联申请接口https://open.unionpay.com/tjweb/api/dictionary?apiSvcId=453,我用的是手机网页支付(WAP支付)2.去个人中心查看......

    2737 0

  • php调用支付宝即时到账

    admin 2020-01-02

    支付宝即时到账,PHP支付宝

    由于之前是供应商开发的系统(asp.net),当初用的是老版本的支付宝,所以,合作商没有给到支付宝公钥和私钥,所以目前想转成PHP的,只能根据以前的配置来开发新的支付。先去找了一下以前的文档https://docs.open.alipay.......

    2425 0

  • php7.4安装zip扩展

    admin 2019-10-09

    Class 'ZipArchive' not found CMake 3.0.2 or higher is required system libzip must be upgraded to version >= 0.11

    假期升级php,从7.0.1升到7.4,升级完成后部分功能受影响,按照项目报错情况开始排查:导出功能报错:Class 'ZipArchive' not found百度了一下,发现时zip拓展没有安装,查看phpinfo,确实没装,开始安装:......

    9220 3